被搞的头大的招商贷登入post

招商袋这个注册还是比较简单的,但是登入我搞的头非常大。实在弄不来智能去精易论坛求助。还好有人写了正确的源码给我。

但是我收到源码,依然是看不太明白,原来刚开始我就错了

https://login.zhaoshangdai.com/cas/captcha.jpg
https://www.zhaoshangdai.com/generatImage.html?

正确的验证码是第一行,而我当时用的是第二行,第二行这个源码用网页_访问_对象()也能获取到验证码图片,然后我先写的是注册子程序,用第二个链接的验证码也能正常注册。怪不得,我后来就是怎么写登入程序都是没反应,也没返回验证码错误的提示。就一直是返回网页源码

还有个问题是,网页是重定向的。需要在post的时候禁止重定向,这个我也看了半天,如果不设置为真。返货的就是空白。

这个招商贷的post很奇怪啊!为什么不用协议头都可以登入。

附上源码:

.版本 2
.支持库 EThread
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 cookies, 文本型

.子程序 __启动窗口_创建完毕

启动线程 (&_图片框1_鼠标左键被放开, , )

.子程序 子程序1_注册
.参数 手机号, 文本型
.参数 密码, 文本型
.参数 图片验证码, 文本型
.参数 手机验证码, 文本型
.局部变量 注册信息, 文本型
.局部变量 网页返回, 文本型



注册信息 = “phone=” + 手机号 + “&password=” + 密码 + “&validCode=” + 图片验证码 + “&messageCode=” + 手机验证码 + “&recommend=”
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.zhaoshangdai.com/investorRegister.html”, 1, 注册信息, cookies, )))
调试输出 (网页返回)

.子程序 _按钮1_注册_被单击

子程序1_注册 (编辑框1_手机号.内容, 编辑框2_密码.内容, 编辑框1_验证码.内容, 编辑框1_手机验证码.内容)


.子程序 _图片框1_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

图片框1.图片 = 网页_访问_对象 (“https://login.zhaoshangdai.com/cas/captcha.jpg”, 0, , cookies)


.子程序 _按钮1_获取手机验证码_被单击
.局部变量 网页返回, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.zhaoshangdai.com/sendPhoneValidation.html?phone=” + 编辑框1_手机号.内容, 0, , cookies, )))

.判断开始 (寻找文本 (网页返回, “执行成功”, , 假) ≠ -1)
    按钮1_获取手机验证码.标题 = “已发送”
.默认
    按钮1_获取手机验证码.标题 = “重新发送”
.判断结束


调试输出 (网页返回)

.子程序 子程序1_登入
.参数 手机号, 文本型
.参数 密码, 文本型
.参数 验证码, 文本型
.局部变量 提交信息, 文本型
.局部变量 网页返回, 文本型
.局部变量 execution, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://login.zhaoshangdai.com/cas/login?target_type=P2p&loginType=WEB&service=https%3A%2F%2Fwww.zhaoshangdai.com%3A443%2Fuser%2Faccount%2Fdetail.html”, 0, , cookies)))

execution = 编码_URL解码 (文本_取出中间文本 (网页返回, “execution” + #引号 + “ value=” + #引号, #引号))

提交信息 = “username=” + 手机号 + “&password=” + 密码 + “&captcha=” + 验证码 + “&execution=” + execution + “&_eventId=submit&geolocation=”
' 调试输出 (提交信息)
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://login.zhaoshangdai.com/cas/login?target_type=P2p&loginType=WEB&service=https%3A%2F%2Fwww.zhaoshangdai.com%3A443%2Fuser%2Faccount%2Fdetail.html”, 1, 提交信息, cookies, , , , , 真)))
调试输出 (网页返回)

.子程序 _按钮1_登入_被单击

子程序1_登入 (编辑框1_手机号.内容, 编辑框2_密码.内容, 编辑框1_验证码.内容)

https://pan.baidu.com/s/1lgbvUDHdHHBwjEXWPCFdpw

提取码:ya62

上面的手机号和密码公开了,不是什么重要的信息

易语言 启动线程()命令

启动线程 (&_图片框1_鼠标左键被放开, , )

必须先点 菜单栏—工具—支持库配置—-勾选✔多线程支持库 2.0版

如果不按照上面的操作,启动线程()这个命令是无效的。我刚开始也输入进去也没弹出这个命令,就百度了一下,原来是这样子的,找出了启动线程无法使用的问题,

借此记录下易语言学习知识

易语言-中关村post学习

我只是个易语言新手,刚学post。记录下遇到的问题

中关村post主要有两个难点。

1.密码MD5 需要在密码后面+zol,再进行MD5

校验_取md5 (到字节集 (编辑框2_密码.内容 + “zol”))

用的是精易模块的 校验_取md5()

2.必须带cookie

post里面没找到cookie,从http://www.zol.com.cn/ 页面的Request Headers里找到个cookie。直接提交的时候带上这个cookie。就可以正常登入

cookie中参数长,可以删除部分,只取ip_ck段

编码_usc2到ansi ()

网页返回的信息记得要编码,不然不是中文链接https://pan.baidu.com/s/1zhbNMT33dPhyOVfEVFeEJQ 提取码: ktss

易语言.DZ论坛账号注册机,自动回帖,自动发布文章软件

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 cookies, 文本型
.程序集变量 formhash, 文本型
.程序集变量 cookies_, 文本型

.子程序 __启动窗口_创建完毕



.子程序 子程序1_注册
.参数 账号, 文本型
.参数 密码, 文本型
.参数 邮箱, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 0, , , cookies)))
formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = 文本_替换 (#提交信息, , , , “4165651”, 账号, “123123”, 密码, “1231313@163.com”, 邮箱, “1930aa2a”, formhash)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 1, 提交信息, cookies, cookies_, #协议头)))
cookies_ = 网页_Cookie合并更新 (cookies, cookies_)
编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “感谢您注册”, , 假) ≠ -1)
    信息框 (“注册成功”, 0, , )
.默认
    信息框 (“注册失败”, 0, , )
.判断结束


.子程序 子程序1_生成账号
.局部变量 账号, 文本型
.局部变量 密码, 文本型
.局部变量 邮箱, 文本型

置随机数种子 ()
账号 = 到文本 (取随机数 (100000, 999999))
密码 = 账号
邮箱 = 账号 + “@qq.com”
编辑框1_账号.内容 = 账号
编辑框2_密码.内容 = 密码
编辑框3_邮箱.内容 = 邮箱
调试输出 (账号, 密码, 邮箱)

.子程序 _时钟1_周期事件

子程序1_生成账号 ()
子程序1_注册 (编辑框1_账号.内容, 编辑框2_密码.内容, 编辑框3_邮箱.内容)


.子程序 子程序1_登入
.局部变量 提交信息, 文本型
.局部变量 网页返回, 文本型

' 网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs”, 0, , , cookies)))
' formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)
' 提交信息 = “formhash=” + formhash + “&referer=https%3A%2F%2Fdooqiu.com%2Fbbs%2F&loginfield=username&username=” + 编辑框1_账号.内容 + “&password=” + 编辑框2_密码.内容 + “&questionid=0&answer=”
' 网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=logging&action=login&loginsubmit=yes&handlekey=login&loginhash=LxOcz&inajax=1”, 1, 提交信息, cookies, , )))
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/member.php?mod=logging&action=login&loginsubmit=yes&infloat=yes&lssubmit=yes&inajax=1”, 1, “fastloginfield=username&username=” + 编辑框1_账号.内容 + “&password=” + 编辑框2_密码.内容 + “&quickforward=yes&handlekey=ls”, , cookies_)))





.判断开始 (寻找文本 (网页返回, “https://www.dooqiu.com/bb”, , 假) ≠ -1)
    信息框 (“登入成功”, 0, , )
.默认
    信息框 (“登入失败”, 0, , )

.判断结束
编辑框1.内容 = 网页返回

.子程序 子程序1_回帖
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型
.局部变量 帖子地址, 文本型
.局部变量 fid, 文本型
.局部变量 tid, 文本型

帖子地址 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (编辑框2_帖子地址.内容, 0, , cookies_, )))
formhash = 文本_取出中间文本 (帖子地址, “formhash” + #引号 + “ value=” + #引号, #引号)
fid = 文本_取出中间文本 (帖子地址, “fid = parseInt('”, “')”)
tid = 文本_取出中间文本 (帖子地址, “tid = parseInt('”, “')”)

帖子地址 = “https://www.dooqiu.com/bbs/forum.php?mod=post&action=reply&fid=” + fid + “&tid=” + tid + “&extra=page%3D1&replysubmit=yes&infloat=yes&handlekey=fastpost&inajax=1”

提交信息 = 到文本 (“message=” + 编码_URL编码EX (编辑框2_回帖内容.内容) + “&posttime=1552730287&formhash=” + formhash + “&usesig=1&subject=++”)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (帖子地址, 1, 提交信息, cookies_, , #回帖协议头)))

编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “回复发布成功”, , 假) ≠ -1)
    信息框 (“回帖成功”, 0, , )
.默认
    信息框 (“回帖失败”, 0, , )
.判断结束


.子程序 _按钮1_登入_被单击

子程序1_登入 ()

.子程序 _按钮1_无限回帖_被单击

时钟2_无限回帖.时钟周期 = 16000

.子程序 _时钟2_无限发布_无限回帖_周期事件



子程序1_回帖 ()


.子程序 _按钮1_无限发布_登入_被单击

子程序1_登入 ()

.子程序 _按钮1_注册_被单击

子程序1_注册 (编辑框1_账号.内容, 编辑框2_密码.内容, 编辑框3_邮箱.内容)


.子程序 _按钮1_无限发布_登入_无限注册_被单击

时钟1.时钟周期 = 3000


.子程序 _按钮1_回帖_被单击

子程序1_回帖 ()

.子程序 子程序1_发布文章
.局部变量 板块地址, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

板块地址 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/forum.php?mod=post&action=newthread&fid=2&extra=&topicsubmit=yes”, 0, , cookies_)))

formhash = 文本_取出中间文本 (板块地址, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = “formhash=” + formhash + “&posttime=1552896141&wysiwyg=1&subject=” + 编码_URL编码EX (编辑框2_文章标题.内容) + “&message=” + 编码_URL编码EX (编辑框2_回帖内容.内容) + “&replycredit_extcredits=0&replycredit_times=1&replycredit_membertimes=1&replycredit_random=100&readperm=&price=&tags=&rushreplyfrom=&rushreplyto=&rewardfloor=&replylimit=&stopfloor=&creditlimit=&allownoticeauthor=1&usesig=1&save=”
调试输出 (提交信息)
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/forum.php?mod=post&action=newthread&fid=2&extra=&topicsubmit=yes”, 1, 提交信息, cookies_, , )))
调试输出 (网页返回)
.判断开始 (寻找文本 (网页返回, “您的朋友访问此链接后”, , 假) ≠ -1)
    信息框 (“发布成功”, 0, , )
.默认
    信息框 (“发布失败”, 0, , )
.判断结束


.子程序 _时钟2_无限发布_周期事件

子程序1_发布文章 ()

.子程序 _按钮1_无限发布_被单击

时钟2_无限发布.时钟周期 = 16000

.子程序 _按钮1_发布文章_被单击

子程序1_发布文章 ()

这是我跟着lazy的视频学着跟着写的dz论坛注册机,自动刷帖,自动发布文章功能。纯粹学习易语言post。

我是个新手,第一次接触post,易语言基础也只看了一遍忘记的差不多了,有些写起来还是有点吃力的,总算差不多搞明白了。DZ论坛是我自己搭建的,就是为了做这个软件用。暂时还不会关闭,大家也可以用来自己写写看。哪里不会可以留言。应该能解决小问题

源码附上https://pan.baidu.com/s/1nIL9dY878zjizo9aEhqfOg 提取码: qvak

易语言

.版本 2

.子程序 子程序1_注册
.参数 账号, 文本型
.参数 密码, 文本型
.参数 邮箱, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 0, , , cookies)))
formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = 文本_替换 (#提交信息, , , , “4165651”, 账号, “123123”, 密码, “1231313@163.com”, 邮箱, “1930aa2a”, formhash)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 1, 提交信息, cookies, cookies_, #协议头)))
cookies_ = 网页_Cookie合并更新 (cookies, cookies_)
编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “感谢您注册”, , 假) ≠ -1)
    信息框 (“注册成功”, 0, , )
.默认
    信息框 (“注册失败”, 0, , )