被搞的头大的招商贷登入post

招商袋这个注册还是比较简单的,但是登入我搞的头非常大。实在弄不来智能去精易论坛求助。还好有人写了正确的源码给我。

但是我收到源码,依然是看不太明白,原来刚开始我就错了

https://login.zhaoshangdai.com/cas/captcha.jpg
https://www.zhaoshangdai.com/generatImage.html?

正确的验证码是第一行,而我当时用的是第二行,第二行这个源码用网页_访问_对象()也能获取到验证码图片,然后我先写的是注册子程序,用第二个链接的验证码也能正常注册。怪不得,我后来就是怎么写登入程序都是没反应,也没返回验证码错误的提示。就一直是返回网页源码

还有个问题是,网页是重定向的。需要在post的时候禁止重定向,这个我也看了半天,如果不设置为真。返货的就是空白。

这个招商贷的post很奇怪啊!为什么不用协议头都可以登入。

附上源码:

.版本 2
.支持库 EThread
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 cookies, 文本型

.子程序 __启动窗口_创建完毕

启动线程 (&_图片框1_鼠标左键被放开, , )

.子程序 子程序1_注册
.参数 手机号, 文本型
.参数 密码, 文本型
.参数 图片验证码, 文本型
.参数 手机验证码, 文本型
.局部变量 注册信息, 文本型
.局部变量 网页返回, 文本型



注册信息 = “phone=” + 手机号 + “&password=” + 密码 + “&validCode=” + 图片验证码 + “&messageCode=” + 手机验证码 + “&recommend=”
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.zhaoshangdai.com/investorRegister.html”, 1, 注册信息, cookies, )))
调试输出 (网页返回)

.子程序 _按钮1_注册_被单击

子程序1_注册 (编辑框1_手机号.内容, 编辑框2_密码.内容, 编辑框1_验证码.内容, 编辑框1_手机验证码.内容)


.子程序 _图片框1_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

图片框1.图片 = 网页_访问_对象 (“https://login.zhaoshangdai.com/cas/captcha.jpg”, 0, , cookies)


.子程序 _按钮1_获取手机验证码_被单击
.局部变量 网页返回, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.zhaoshangdai.com/sendPhoneValidation.html?phone=” + 编辑框1_手机号.内容, 0, , cookies, )))

.判断开始 (寻找文本 (网页返回, “执行成功”, , 假) ≠ -1)
    按钮1_获取手机验证码.标题 = “已发送”
.默认
    按钮1_获取手机验证码.标题 = “重新发送”
.判断结束


调试输出 (网页返回)

.子程序 子程序1_登入
.参数 手机号, 文本型
.参数 密码, 文本型
.参数 验证码, 文本型
.局部变量 提交信息, 文本型
.局部变量 网页返回, 文本型
.局部变量 execution, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://login.zhaoshangdai.com/cas/login?target_type=P2p&loginType=WEB&service=https%3A%2F%2Fwww.zhaoshangdai.com%3A443%2Fuser%2Faccount%2Fdetail.html”, 0, , cookies)))

execution = 编码_URL解码 (文本_取出中间文本 (网页返回, “execution” + #引号 + “ value=” + #引号, #引号))

提交信息 = “username=” + 手机号 + “&password=” + 密码 + “&captcha=” + 验证码 + “&execution=” + execution + “&_eventId=submit&geolocation=”
' 调试输出 (提交信息)
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://login.zhaoshangdai.com/cas/login?target_type=P2p&loginType=WEB&service=https%3A%2F%2Fwww.zhaoshangdai.com%3A443%2Fuser%2Faccount%2Fdetail.html”, 1, 提交信息, cookies, , , , , 真)))
调试输出 (网页返回)

.子程序 _按钮1_登入_被单击

子程序1_登入 (编辑框1_手机号.内容, 编辑框2_密码.内容, 编辑框1_验证码.内容)

https://pan.baidu.com/s/1lgbvUDHdHHBwjEXWPCFdpw

提取码:ya62

上面的手机号和密码公开了,不是什么重要的信息

留下评论

电子邮件地址不会被公开。 必填项已用*标注