易语言

.版本 2

.子程序 子程序1_注册
.参数 账号, 文本型
.参数 密码, 文本型
.参数 邮箱, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 0, , , cookies)))
formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = 文本_替换 (#提交信息, , , , “4165651”, 账号, “123123”, 密码, “1231313@163.com”, 邮箱, “1930aa2a”, formhash)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 1, 提交信息, cookies, cookies_, #协议头)))
cookies_ = 网页_Cookie合并更新 (cookies, cookies_)
编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “感谢您注册”, , 假) ≠ -1)
    信息框 (“注册成功”, 0, , )
.默认
    信息框 (“注册失败”, 0, , )

留下评论

电子邮件地址不会被公开。 必填项已用*标注