易语言.DZ论坛账号注册机,自动回帖,自动发布文章软件

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 cookies, 文本型
.程序集变量 formhash, 文本型
.程序集变量 cookies_, 文本型

.子程序 __启动窗口_创建完毕



.子程序 子程序1_注册
.参数 账号, 文本型
.参数 密码, 文本型
.参数 邮箱, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 0, , , cookies)))
formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = 文本_替换 (#提交信息, , , , “4165651”, 账号, “123123”, 密码, “1231313@163.com”, 邮箱, “1930aa2a”, formhash)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=register&inajax=1”, 1, 提交信息, cookies, cookies_, #协议头)))
cookies_ = 网页_Cookie合并更新 (cookies, cookies_)
编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “感谢您注册”, , 假) ≠ -1)
    信息框 (“注册成功”, 0, , )
.默认
    信息框 (“注册失败”, 0, , )
.判断结束


.子程序 子程序1_生成账号
.局部变量 账号, 文本型
.局部变量 密码, 文本型
.局部变量 邮箱, 文本型

置随机数种子 ()
账号 = 到文本 (取随机数 (100000, 999999))
密码 = 账号
邮箱 = 账号 + “@qq.com”
编辑框1_账号.内容 = 账号
编辑框2_密码.内容 = 密码
编辑框3_邮箱.内容 = 邮箱
调试输出 (账号, 密码, 邮箱)

.子程序 _时钟1_周期事件

子程序1_生成账号 ()
子程序1_注册 (编辑框1_账号.内容, 编辑框2_密码.内容, 编辑框3_邮箱.内容)


.子程序 子程序1_登入
.局部变量 提交信息, 文本型
.局部变量 网页返回, 文本型

' 网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs”, 0, , , cookies)))
' formhash = 文本_取出中间文本 (网页返回, “formhash” + #引号 + “ value=” + #引号, #引号)
' 提交信息 = “formhash=” + formhash + “&referer=https%3A%2F%2Fdooqiu.com%2Fbbs%2F&loginfield=username&username=” + 编辑框1_账号.内容 + “&password=” + 编辑框2_密码.内容 + “&questionid=0&answer=”
' 网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://dooqiu.com/bbs/member.php?mod=logging&action=login&loginsubmit=yes&handlekey=login&loginhash=LxOcz&inajax=1”, 1, 提交信息, cookies, , )))
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/member.php?mod=logging&action=login&loginsubmit=yes&infloat=yes&lssubmit=yes&inajax=1”, 1, “fastloginfield=username&username=” + 编辑框1_账号.内容 + “&password=” + 编辑框2_密码.内容 + “&quickforward=yes&handlekey=ls”, , cookies_)))





.判断开始 (寻找文本 (网页返回, “https://www.dooqiu.com/bb”, , 假) ≠ -1)
    信息框 (“登入成功”, 0, , )
.默认
    信息框 (“登入失败”, 0, , )

.判断结束
编辑框1.内容 = 网页返回

.子程序 子程序1_回帖
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型
.局部变量 帖子地址, 文本型
.局部变量 fid, 文本型
.局部变量 tid, 文本型

帖子地址 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (编辑框2_帖子地址.内容, 0, , cookies_, )))
formhash = 文本_取出中间文本 (帖子地址, “formhash” + #引号 + “ value=” + #引号, #引号)
fid = 文本_取出中间文本 (帖子地址, “fid = parseInt('”, “')”)
tid = 文本_取出中间文本 (帖子地址, “tid = parseInt('”, “')”)

帖子地址 = “https://www.dooqiu.com/bbs/forum.php?mod=post&action=reply&fid=” + fid + “&tid=” + tid + “&extra=page%3D1&replysubmit=yes&infloat=yes&handlekey=fastpost&inajax=1”

提交信息 = 到文本 (“message=” + 编码_URL编码EX (编辑框2_回帖内容.内容) + “&posttime=1552730287&formhash=” + formhash + “&usesig=1&subject=++”)

网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (帖子地址, 1, 提交信息, cookies_, , #回帖协议头)))

编辑框1.内容 = 网页返回
.判断开始 (寻找文本 (网页返回, “回复发布成功”, , 假) ≠ -1)
    信息框 (“回帖成功”, 0, , )
.默认
    信息框 (“回帖失败”, 0, , )
.判断结束


.子程序 _按钮1_登入_被单击

子程序1_登入 ()

.子程序 _按钮1_无限回帖_被单击

时钟2_无限回帖.时钟周期 = 16000

.子程序 _时钟2_无限发布_无限回帖_周期事件



子程序1_回帖 ()


.子程序 _按钮1_无限发布_登入_被单击

子程序1_登入 ()

.子程序 _按钮1_注册_被单击

子程序1_注册 (编辑框1_账号.内容, 编辑框2_密码.内容, 编辑框3_邮箱.内容)


.子程序 _按钮1_无限发布_登入_无限注册_被单击

时钟1.时钟周期 = 3000


.子程序 _按钮1_回帖_被单击

子程序1_回帖 ()

.子程序 子程序1_发布文章
.局部变量 板块地址, 文本型
.局部变量 网页返回, 文本型
.局部变量 提交信息, 文本型

板块地址 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/forum.php?mod=post&action=newthread&fid=2&extra=&topicsubmit=yes”, 0, , cookies_)))

formhash = 文本_取出中间文本 (板块地址, “formhash” + #引号 + “ value=” + #引号, #引号)


提交信息 = “formhash=” + formhash + “&posttime=1552896141&wysiwyg=1&subject=” + 编码_URL编码EX (编辑框2_文章标题.内容) + “&message=” + 编码_URL编码EX (编辑框2_回帖内容.内容) + “&replycredit_extcredits=0&replycredit_times=1&replycredit_membertimes=1&replycredit_random=100&readperm=&price=&tags=&rushreplyfrom=&rushreplyto=&rewardfloor=&replylimit=&stopfloor=&creditlimit=&allownoticeauthor=1&usesig=1&save=”
调试输出 (提交信息)
网页返回 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“https://www.dooqiu.com/bbs/forum.php?mod=post&action=newthread&fid=2&extra=&topicsubmit=yes”, 1, 提交信息, cookies_, , )))
调试输出 (网页返回)
.判断开始 (寻找文本 (网页返回, “您的朋友访问此链接后”, , 假) ≠ -1)
    信息框 (“发布成功”, 0, , )
.默认
    信息框 (“发布失败”, 0, , )
.判断结束


.子程序 _时钟2_无限发布_周期事件

子程序1_发布文章 ()

.子程序 _按钮1_无限发布_被单击

时钟2_无限发布.时钟周期 = 16000

.子程序 _按钮1_发布文章_被单击

子程序1_发布文章 ()

这是我跟着lazy的视频学着跟着写的dz论坛注册机,自动刷帖,自动发布文章功能。纯粹学习易语言post。

我是个新手,第一次接触post,易语言基础也只看了一遍忘记的差不多了,有些写起来还是有点吃力的,总算差不多搞明白了。DZ论坛是我自己搭建的,就是为了做这个软件用。暂时还不会关闭,大家也可以用来自己写写看。哪里不会可以留言。应该能解决小问题

源码附上https://pan.baidu.com/s/1nIL9dY878zjizo9aEhqfOg 提取码: qvak

留下评论

电子邮件地址不会被公开。 必填项已用*标注